Google AdSense (text)

hidden logo stop

Moving

거지 같은 이글루스 광고노출 정책이 싫어서,
새 보금자리(http://blog.leocat.kr/)로 이사감.

[Eclipse] Subclipse 설치 시 "Unable to load default SVN Client"오류 Computer & Program

RHEL(Red Hat Enterprise Linux)에 설치된 Eclipse에 Subclipse를 설치하려고 시도를 했다. 일반적인 방법인 이클립스 애드온 업데이트를 통해 설치했다. 다음 업데이트 주소를 등록하고 (Required) 표시가 된 애드온(Add-on)을 설치했다. 분명히 윈도에서는 이렇게 (Required)만 설치하면 잘 동작했다.

http://subclipse.tigris.org/update_1.6.x

그런데.. SVN repository를 등록하려고 하면 다음과 같은 경고가 나오면서 등록이 되지 않는다. 내용을 보니 SVN Client가 없어서 Subversion 서버에 접속을 할 수 없는 것으로 보이는데..

역시 백방으로 수소문하려고 구글링을 시작했다. 그런데 대부분이 OS X에 대한 얘기뿐이었다. 그리고 OS X은 다른 애드온을 설치하면 해결되는듯 싶다. 헌데 운영체제가 달라서 이 방법으로 해결할 수는 없었다. 그러던 중 Preferences창(Window -> Preferences)을 열어 Team -> SVN의 설정을 보면 "SVN Interface"가 동작하지 않아서 그런 것이라는 얘기가 있었다. 확인해 보니 아래 그림과 같이 "JavaHL (JNI) Not Available"이라고 표시되는 것이다. 정상적으로 표시되면 현재 사용되는 버전이 함께 표시되어야 한다.

이 "SVN Interface"는 Subversion 서버에 접속하기 위해 사용되는 SVN Client이다. 처음 캡쳐 화면의 SVN Client를 로딩할 수 없다는 "Unable to load default SVN Client" 메시지가 이 "SVN Interface"를 사용할 수 없어서 나타나는 메시지인 것이다. 이 문제를 해결하기 위해서는 "SVN Interface"로 사용할 수 있는 SVN Client를 설치해 주면 된다.

"SVN Interface"는 이클립스 애드온 업데이트에서 "Adapter"로 표시된다. "Subversion JavaHL Native Library Adapter"가 동작하지 않으면 다른 Adapter를 사용하자. 아래 그림을 보면 (Not required)로 표시된 "SVNKit Client Adapter"가 있다. 이 Adapter를 사용하면 된다. (분명 Not required로 표시되어 있는데.. 그래서 설치 안 했는데.. TㅅT)

이 Adapter는 아래 애드온 주소를 등록하여 SVNKit을 직접 업데이트 해서 설치할 수도 있다.

http://eclipse.svnkit.com/1.3.x/

그리고 "SVN Interface"를 지금 설치한 "SVNKit Client Adapter"로 바꿔주면 잘 동작할 것이다.

자~~ 그럼 모두들 잘 동작할거라 믿으며 포슷힝은 요기까지~~ TㅂT

핑백

  • eclipse에서 subclipse 설치 시 오류발생 – ThinkCUBES 2017-11-09 17:47:09 #

    ... 이건 또 무슨 말이냐. http://eclipse.svnkit.com/1.3.x/ 저걸 설치해주면 괜찮아진다고 한다. 자세한 설명은 생략한다. 출처 : http://entireboy.egloos.com/4201369 수정 : 다시 보니, subclipse 1.6.x 버전에서 해당 adaptor를 필수 옵션으로 되어 있지 않네. install 화면에서 해당 옵 ... more

덧글

  • jack 2010/01/28 10:20 # 삭제 답글

    안녕하세요 ^^ 해당 오류때문에 고생했는데 덕분에 SVN접속이 가능해 졌습니다. 감사합니다 ^^
  • Sigel 2010/01/28 11:19 #

    도움이 되셨다니 다행입니다.
    저도 온갖 삽질 끝에 해결을 했지요.. 그 후련함이란.. 후우~~ ㅋㅋ
  • 동범이 2010/05/31 01:47 # 삭제 답글

    저도 이 문제 때문에 구글 검색하다가 여기까지 왔어요. ^^

    이 방법대로 해서 잘 해결했습니다. 감사해요~~

    트랙백도 걸고 갑니다~
  • Sigel 2010/05/31 08:52 #

    해결하셔서 저도 기쁘네요.
    좋은 하루 되세요. :)
  • 메타콰이어 2010/08/05 16:44 # 삭제 답글

    정말 감사드립니다!! 이것때문에 고생 했는데.... 단비 같은 내용이네요!!
  • Sigel 2010/08/05 16:51 #

    누추한 곳 까지.. 저야말로 감사합니다.
    잼난 프로그래밍 되세요.
  • 응가 2010/09/16 08:58 # 삭제 답글

    감사해요! 덕분에 잘 해결하고 갑니다 !! ^^
  • Sigel 2010/09/16 08:58 #

    별말씀을요.. 도움이 되었다니 기쁘네요 :)
  • 쫑알이 2010/11/23 09:53 # 삭제 답글

    담아갈게요... 덕분에 해결했어요^^ 구세주!! ㅎㅎ
  • Sigel 2010/11/24 12:47 #

    좋은 정보는 함께 알아야 하는거지요 :)
  • dudaji 2011/05/30 10:18 # 삭제 답글

    감사합니다. 도움이 됬습니다
  • Sigel 2011/05/30 10:24 #

    즐거운 하루 되세요~!!
  • hy 2011/07/15 10:17 # 삭제 답글

    도움이 됬습니다. 고맙습니다~
  • Sigel 2011/07/15 10:18 #

    수고하세요. :)
  • 감사 2011/09/06 20:11 # 삭제 답글

    정보 감사합니다.
  • Sigel 2011/09/07 11:51 #

    행복하세요.
  • SUN 2012/02/15 11:05 # 삭제 답글

    담아갈께요. 해결됐으면 좋겠네요 ㅎㅎ
  • Sigel 2012/02/15 16:53 #

    출처만 남겨주세요.
  • 사비 2012/02/21 17:37 # 삭제 답글

    감사합니다.
  • Sigel 2012/02/22 15:45 #

    :D
  • 벤지 2013/07/09 15:27 # 삭제 답글

    감사합니다....
  • Sigel 2013/07/09 16:16 #

    도움이 됐나요?? 기쁘네요
  • 저도~ 2014/11/02 20:55 # 삭제 답글

    아마도 Not Required 는 서버 기준으로 설치할 때 필요 없다고 말한것 같네요.
    (아오 왜 헷갈리게 적어놓은거야... ㅠㅠ)
    덕분에 잘 해결하고 갑니다! 감사합니다~~~
  • Sigel 2014/11/04 02:16 #

    네 헷갈리게 적혀 있어요 TㅅT
댓글 입력 영역

Google AdSense (text/image)